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Proprietary and Restricted Rights Notice 
 
Information within this document is subject to change without notice. No part of this documentation may be 
reproduced in any form or by any means including photocopying, recording or microfilming or by any information 
storage and retrieval system including a web site, without written permission of 3D Systems.  
 
No liability is assumed by 3D Systems with respect to the use of the information contain herein. While every 
precaution has been taken in the preparation of this documentation, 3D Systems assumes no responsibility for 
errors or omissions that may appear in this document. References in this document do not constitute an 
endorsement of any products or services. 
 
© 1996-2019 3D Systems All rights reserved 
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About Us 
3D Systems is a leading global provider of 3D content-to-print solutions including 3D printers, print materials and 
on-demand custom parts services for professionals and consumers alike. The company also provides CAD 
modeling, reverse engineering and inspection software tools and consumer 3D printers, apps and services. Its 
expertly integrated solutions replace and complement traditional methods and reduce the time and cost of 
designing and manufacturing new products. 3D Systems’ products and services are used to rapidly design, 
communicate, prototype or produce real functional parts, empowering customers to create and make with 
confidence. 
 
More information on the company is available at www.3DSystems.com 
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Introduction 
Overview 

This guide covers the fundamental commands and workflows utilizing Geomagic Essentials software and covers 
the fundamental commands, concepts and workflows.  

 

Intended Audience 
This guide is targeted to users of Geomagic products who require an entry level understanding of captured data 
processing. 
 

Prerequisites 
None 
 
 

Guide Conventions 

Bold Text 

Indicates  mouse button clicks to locate a command in the user interface in the format of 
Tab > Group > Command, example: 
View > Navigation > Fit Model to View 

View (Tab) > Navigation (Group) > Fit Model to View (Command) 
Bold text also may be used to draw attention to or create emphasis for key concepts in 
activity steps. 

● A dotted bullet indicates an actionable item in the training activities. 

 This symbol is used to identify additional information within the context of an activity step. 
Text following this symbol is not actionable within an activity step. 

 A circled bullet is an information item found outside of an activity. 

 This symbol is used to strongly advise or convey important information when used. 
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Graphical User Interface 
Introduction to the Graphical User Interface (GUI).  

ACTIVITY: Getting Started 

Objective 
Locate the primary components of the application user interface. 
 

 
1. From the Windows Start button, select Start > All Programs > 3D Systems > 

Geomagic Essentials to start the application. 

 or 

   
2. From the Desktop, double-click the Geomagic Essentials icon to start the application. 

The application will start as shown in Figure 1. 

 Clicking a Tab will change the current ribbon to display different command Tab Groups. 

 In the Panel Window area, the Model Manager Panel displays objects that are opened, imported or created. 

 The Getting Started tab above the Graphics Window provides access to the Recent Files list, Tasks and other 
useful Resources. 

 

Figure 1 – Graphical User Interface 

File Open 

 
 

1. Click the Getting Started tab and select Open from the Tasks list or click the 
Application Button at the top left corner of the application and select Open from the 
menu. 

Application Button Tabs Groups 
Search 

Panel Window 
Graphics Window Progress Meter 

Command 
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 Use the Open Files dialog to navigate to the training files folder. Choose TR-00.wrp 
from the Open Files dialog. 

 Files in Geomagic Essentials format have a .WRP extension. 

 Click Open. The file is loaded and displayed in the Graphics Window, see Figure 2. 

 When a data file is opened in Geomagic Essentials, the Graphics tab activates in the Graphic Window.  

 

Figure 2 

End of Activity 

  

Graphics Window Tab Right-Side Toolbar 

Overlay Axes Indicator 
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Right-Side Toolbar 
This toolbar contains commonly used view and selection commands.  

Axes Indicator (Navigation Widget) 
The Axes Indicator displays the current orientation of the model relative to the World CSYS. (This is not 
coordinate system 0, 0, 0.) The Axes Indicator allows the user to control the view orientation by selecting 
elements of the indicator. 

 
Showing World CSYS Orientation 

 
Planar Rotation - 90° 

 
Change Orientation – Y-Axis 

Overlay 
Information displayed in the Overlay area is controlled in the Overlay roll-
up group of the Display panel. 
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Navigation & Selection 
This section uses a polygon object as an example; all commands in this section work the same for point and CAD 
objects except where noted. 
 

Mouse Commands 

ACTIVITY: Using the Mouse 

Objective 
Learn the mouse operations in the Graphics Window. 
 

Pan and Zoom 

 

1. Position the current view by using the Pan command. 

 Place your cursor in the Graphics Window, press the ALT key and hold down the 
right-mouse button (RMB). 

 Move the mouse right or left to pan from one side to the other. Move the mouse 
away or towards you to pan from top to bottom. 

 Release the right-mouse button (RMB) to stop the pan operation. 

 

2. Change the magnification of the object in the Graphics Window by using the Zoom 
command. 

 Place your cursor in the Graphics Window at a location of interest and use the 
scroll-wheel to zoom in by rolling the scroll-wheel towards you. To zoom out, roll 
the scroll-wheel away from you. 

 The Zoom command is sensitive to cursor position, move the cursor and zoom in/out at the area of interest. 

 
3. Cause all objects to Fit within the Graphics Window. 

 Click the Fit Model to View icon on the Right-Side Toolbar. 

View Rotation 

 

1. Place the cursor in the Graphics Window; press and hold the middle-mouse button 
(MMB). 

 Move the mouse in the Graphics Window to rotate the object. 

 Moving the mouse inside the circle that appears in the Graphics Window performs 
a spherical (3D) rotation. 

 Moving the mouse outside the circle that appears in the Graphics Window performs 
a planar rotation, parallel to the current view. 
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2. The default center of view rotation is the bounding box center of all visible objects. To 

change the center of rotation: 

 In the Graphics Window, right-mouse button (RMB)-click to see the right-click 
menu.  

 Select Set Rotation Center from the right-click menu. 

 A special cursor will appear for Set Rotation Center. 

 Left-mouse button (LMB)-click a location on the object in the Graphics Window. 

 Rotate the object again; notice how the object rotates about the last selected 
location point. 

 If Toggle Dynamic Rotation Center is active in the Right-Side Toolbar, setting the rotation using this method 
will have no effect. 

 3. In the Graphics Window, right-mouse button (RMB)-click to see the right-click 
menu.  

 Select Reset Rotation Center from the right-click menu to restore the rotation 
center to the center of the visible object(s) bounding box. 

Viewing Tools 

 

1. Locate the Predefined Views fly-out on the Right-Side Toolbar and click through 
each of the icons on the fly-out to familiarize yourself with both the fly-out behavior 
and changing the view orientation. 

 Predefined Views are orthogonal to the World Coordinate System (World CSYS). 

 
2. The Reset Current View icon when clicked will restore the last predefined view, reset 

the rotation center and zoom to view all visible objects. 

 

3. Locate the Shading fly-out on the Right-Side Toolbar and click the icons to change 
between Smooth Shading and Flat Shading. 

 Smooth Shading diffuses pixels of the active object causing it to appear smoother than it is. Flat Shading 
reveals the object as it actually is. 

 

4. The Toggle All Features icon toggles on/off the visibility of all Features in the 
Graphics Window. Left-mouse button (LMB)-click the icon several times to 
view/hide the Feature object. If there are no available Features, the icon will be 
grayed out. 

 Features are Geomagic Essentials objects that have many uses. 

 

5. Fit Model to View will cause all objects to Fit within the Graphics Window. 

 Fit Model to View will zoom to the extents of all visible objects. 

 

6. Toggle Dynamic Rotation Center will place the center of rotation at the cursor 
location each time the left-mouse button (LMB) is clicked on the active object. 

 This command is activated by clicking the icon and remains on until it is clicked again. When active, the 
background color of the icon is orange. 
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Selection Tools 

 
 
 

 
 

1. Click the Select Visible icon from the Right-Side Toolbar. 

 Causes the selection tools to operate only on visible data in the current view, obscured data will not be 
selected. 

 Click the Rectangle Selection Tool icon. 

 Place the cursor on the object, click and hold the left-mouse button (LMB). 

 Drag your cursor to define the second corner of selection zone. As you move the 
cursor, a rectangle is visible in the area to be selected.  

 Release the left-mouse button (LMB). The polygons in the selection zone turn 
red, indicating that they are selected for some type of operation. 

 
2. Hold down the CTRL key while selecting in the same area from the previous step (red). 

 Holding CTRL when using any selection tool will cause any area selected to be deselected. 

 
3. Create more selections using the Rectangle Selection Tool icon. 

 
 

 
 

4. Delete selected areas by pressing the DEL key or clicking Scan > Repair > Delete on 
the ribbon. 

 Press CTRL+Z to undo the last command. 

 
 
 
 
 

 

5. Select and delete additional areas using the Circle Selection Tool, Line Selection 
Tool, Paint Brush Selection Tool, and Lasso Selection Tool. 

 Select the tools from the Right-Side Toolbar and make selections on the object in 
the Graphics Window. 

 Press the DEL key to delete selected areas. 

 The Line Selection Tool is active only on polygon objects. 

 

 
Figure 3 - Example of selected areas 
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 6. Press CTRL+Z to recover (undo) the most recently deleted areas of the object. 

 There is one level of undo in the application.  
 

7. Press CTRL+C to clear all selections. 

 

8. Click the Select Through icon on the Right-Side Toolbar and select an area on the 
object using the Rectangle Selection Tool. 

 Rotate the object around to view the other side of your selection. Notice that Select 
Through causes the current selection tool to affect all areas within the selection 
boundary, not just those visible on screen, see Figure 4 and Figure 5. 

 Press CTRL+C to clear all selected areas. 

 

 
Figure 4 - Initial Selection 

 
Figure 5 - Result of Selection 

 9. Click the Select Visible icon on the Right-Side Toolbar to toggle off Select Through 
mode. 

 10. Press CTRL+C to clear all selections. 

 
 
 
 
 
 
 
 

11. Rotate the object as shown in 
Figure 6. 

 A polygon object has a scan side that is blue in 
color (normal) and a back face side that is 
yellow in color. 

 The Select Backfaces Mode is On by default. 
Turning it Off disables direct selection of back 
faces (yellow side). 

 
Figure 6 
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 12. Make the selection with your cursor 
as shown in Figure 7. 

 Notice that both the normal side and the back 
face side may be selected. 

 
Figure 7 – Select Backfaces Mode: ON 

 13. Press CTRL+C to clear all selections. 

 14. Click the Select Backfaces Mode 
icon on the Right-Side Toolbar to 
turn it Off. 

  When turned Off, selection tools cannot directly 
select back faces.  

15. Make the selection again as shown in 
Figure 8. 

 Notice that no back faces (yellow) were selected 
in the area specified. 

 
Figure 8 – Select Backfaces Mode: OFF 

 16. Press CTRL+C to clear all selections. 

 17. Select Isometric View from the 
Predefined Views fly-out on the 
Right-Side Toolbar to rotate the 
object into an isometric view as 
shown in Figure 9.  

 
Figure 9 

 
18. From the Right-Side Toolbar, click the Polyline Selection Tool icon. 

 The Polyline Selection Tool will create a selection defined by clicking locations to define a boundary. 
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 19. Click a set of points as shown in 
Figure 10. As you click, a boundary 
line will appear from click to click. 

 To define the last point in your 
Polyline Selection, move your 
cursor to the last location and 
press the right-mouse button 
(RMB) to end the process and 
make your selection. 

 Rotate the object slightly to 
review the selected data. 

 Press CTRL+C to clear the 
selection. 

 
Figure 10 

 
20. Click the Custom Region Selection Tool icon on the Right-Side Toolbar. 

 The Custom Region Selection Tool will find both visible and non-visible areas within the bounded area you 
create. If the Custom Region Selection Tool is accidentally started it can be stopped by pressing the ESC key. 

 21. Click a set of points as shown in Figure 11. As you click around the region, a white 
boundary line will appear from click to click. 

 When you get close to your starting point, press the right-mouse button (RMB) to 
close the selected boundary. 

 

 
Figure 11 

 
Figure 12 

 22. When the boundary is closed, it should appear as shown in Figure 12 with the interior 
area selected (red). 

 Data inside the boundary not visible to you in the current view, such as undercuts or back-draft conditions will 
also be selected.  

 Rotate the object slightly to see data not visible in the current view is selected.  

 23. Press CTRL+C to clear the selection. 
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24. Select adjacent triangles that meet at a specified angle of less than 3 degrees. 

 Click the Paint Brush Selection Tool icon on the Right-Side Toolbar. 

 Click the Select by Angle Mode icon on the Right-Side Toolbar, and select the flat 
area as shown in Figure 13. 

 Adjacent triangles in the polygon mesh that are within a 3 degree angle (default) of each other will be selected 
as shown in Figure 14. 

 

 
Figure 13 

 
Figure 14 

 25. Press CTRL+C to clear the selection. 

 26. Adjust selection Crease Angle. 

 Press CTRL+X to open the Options dialog. 

 Locate the Display category on the dialog and click Selection. 

 On the Selection page; locate Crease Angle in the Select by Crease Angle group 
and change the value to 1.5. 

 Click OK to dismiss the Options dialog. 

 27. Make the same selection as before with 
Select by Angle Mode still active. 

 The selected area should appear as 
shown in Figure 15. 

 Click the Select by Angle Mode icon 
again to turn it Off. 

 This type of selection mode has many uses, 
including finding areas that are flat for other 
commands. The smoothness of a polygon object 
affects how this selection mode works. 

 This tool is only active on polygon objects. 

 
Figure 15 

 The majority of commands in the application operate using the following selection syntax: 

 If nothing is selected when a command is activated; the command will affect the entire active object or 
all active objects. 

 If a selection is present when a command is activated; the command will affect the selected area only. 

End of Activity 
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Panel Window 
Panel Tabs 

ACTIVITY: Exploring the Panels 

Objective 
Explore the tabs of the Panel Window. 
 If you accidentally hide a panel and want to make it visible again, click View > Panels > Panel Visibility and 

select the hidden panel from the list that appears, to make it visible. 

Training File 
TR-00.wrp 

 1. Click the File Open icon on the Quick Access Toolbar. 

 Use the Open Files dialog to navigate to the folder where the training files reside. 
Choose TR-00.wrp from the Open Files dialog. 

 Click the Open button. 

 

2. The Model Manager Panel tab contains objects either created or loaded into the 
current session. A right-click menu is available on objects in the tree, the 
commands available from the right-click menu change depending on the type of 
object selected.  

 

3. Objects with a “+” sign next to them are nested in a collapsed branch of the tree. 
Clicking the “+” sign will expand the tree to reveal any nested objects. 

 Items on the tree may be renamed, deleted, hidden, saved out exclusively of other objects, or made into 
groups. 

 4. The Display Panel tab contains the following roll-up groups of display options; 
General, Geometry Display, Lighting and Overlay. 

 A roll-up group can be expanded or collapsed by clicking the title bar containing the roll-up group name. 

 5. The General roll-up group contains visibility options. 

 Clicking in a checkbox will toggle an option on/off. 

  Place/remove a checkmark in each of the World CSYS, Axes Indicator, and 
Bounding Box checkbox’s to toggle visibility of each item in the Graphics 
Window. 

 You may have to zoom out to see the location of the World CSYS which is positioned at 0,0,0 of the World 
Coordinate System. 

  Place a checkmark in the Transparency checkbox and move its slider control to 
change the opacity/transparency of the active object in the Graphics Window. 

 Remove the checkmark from the Transparency checkbox. 
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6. Set the view to Top View. 

 Click Top View icon on the Right-Side Toolbar. 

 The Right-Side Toolbar contains fly-out toolbars; to activate a fly-out, click a button with a down arrow and 
a toolbar will expand, select the desired button from the fly-out to activate the command.  

 

7. Clip the displayed object to view 
inside of it. 

 Click the View Clipping 
checkbox in the General roll-up 
group. 

 Select the Isometric View icon 
in the Right-Side Toolbar, see 
Figure 16. 

 
Figure 16 – Clipped View 

 8. Adjust the slider control to 
change the value of View Clipping 
plane. Parts of the object are 
clipped (hidden from view).  

 Click the Show Clipping Plane 
checkbox to see the View 
Clipping plane, see Figure 17. 

 This command is useful for working from the 
inside of closed objects. 

 
Figure 17 – Clipping Plane Visible 

 9. Change the orientation of the view clipping plane. 

 Remove the checkmark from the View Clipping checkbox. 

 Rotate the object in the Graphics Window. 

 Place a checkmark in the View Clipping checkbox. 

 Notice how the view is clipped parallel to the screen. 

 Adjust the slider control to see the results. 

 10. Remove the checkmark from the View Clipping checkbox. 

 11. The Points Display Size and Edge Display Size options control the size of points in 
a point cloud object and the mesh edge size in a polygon object. 

 12. The Static Display Percentage and Dynamic Display Percentage options limit the 
amount of data visible when at rest (static) or when moved (dynamic) with rotate, 
zoom, or pan. 

  This will increase display rendering speed, which is useful when working with large scan data files. 
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 13. The Lighting roll-up group provides options to change lighting themes from one to 
four lights and has slider controls. Experiment with the Lighting controls and themes 
to find one that best suits your taste. 

 You can use the Reset button to return all options to their defaults. 

 14. The Overlay roll-up group controls the visibility of information that shows up in the 
lower left corner of the Graphics Window. 

 Place a checkmark in the Model Information, Bounding Box Dimensions and 
Memory Usage checkboxes. Note the information that displays into the Overlay 
section of the Graphics Window. 

 Model Information displays the total number of elements (points, polygons, etc.) of the active object, plus 
the number of currently selected elements. 

 It is recommended that the Model Information option be left active. The information provided is 
helpful when editing objects. 

 
 

15. The Dialog Panel tab automatically displays dialog based commands when they are 
activated. If no command is active, then this Panel is empty.  

 When a command is active in the Dialog Panel tab and focus has been shifted to another Panel tab in the 
Panel Window; you will not be able to access other commands. Return to the Dialog Panel tab and complete 
the currently active command to continue. 

End of Activity 
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Dialogs 
Geomagic Essentials dialogs have several controls in common with each other; this section describes the most 
commonly used controls and conventions. The majority of Geomagic Essentials commands are dialog based. 

 
OK button; accepts any changes made while in the dialog and exits the dialog. 

 Cancel button; discards any changes made while in the dialog and exits the dialog. 

 

Apply button; updates the command to any changes made while in the dialog – this is useful to 
preview parameter/option changes while making adjustments, without committing to the 
current settings. 

If an Apply button is present in a dialog, you must press it to activate the command. 

 Next button; Analogous to OK and restarting the command. 

 Reset button; resets dialog parameters to defaults; equivalent to restarting command. 

Slider Control; when scrolled to the right, increases parameter affected. 

 
Roll-Up Groups; when rolled up, an arrow in the group title points downward, see Figure 18. Clicking anywhere on 
a rolled up group title will expand the group and reveal additional dialog elements, values, inputs or activate 
extended commands, see Figure 19. 

 
Figure 18 

 
 

 
Figure 19 
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Context Menus 
Geomagic Essentials has several context menus activated by right-clicking in one of three locations; at the top of 
the screen on a user interface element, on an object in the Model Manager Panel tab and in the Graphics 
Window. 

 

User Interface Context Menu 

 

 Quickly add any command to the Quick Access Toolbar. 

 Display the Quick Access Toolbar below the ribbon. 

 Hide the ribbon; reappears when a tab is clicked. 

 

Model Manager Context Menu 
 
 
 
 
 
 

 Display’s the name of the selected object. 

 Hide the object in the Graphics Window; if the object is 
currently hidden the menu will display the Show option. 

 Rename the selected object; this can also been done by 
double-clicking the object in the Model Manager Panel tree. 

 Delete, removes the selected object from the current session 
– this action cannot be undone. 

 Save the current object out to a file in one of the supported 
formats for the data type of the object. 

 Duplicate creates an exact copy of a top level object on the 
tree; if the object has branch nodes they will also be copied. 
Useful for creating duplicates for alternative workflows or a 
backup object. 

 Pin/Ignore; Used only for Global Registration command. Pin 
will constrain the location of the selected object. Ignore is 
useful when a one or more of scans are in a group and you do 
not want them used in Global Registration command. 

 Create Group creates a folder object on the Model Manager 
Panel tree that can be used to store objects of the same data 
type. 

 Properties… displays the properties of the selected object, 
useful when a Feature object is selected. 
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Graphics Window Context Menu 

 
 

 With no selection made in the Graphics Window a context 
menu of commonly used view and selection commands 
are available. 

 Default right-click menu shown. 

 

 

 

 With a selection made in the Graphics Window a context 
menu with data sensitive shortcuts is added to the top of 
the context menu. 

 Polygon context menu shown. 

 

 

Search 
 The Search Box at the top right corner of the application builds a ribbon based on what is typed into 

the text box. The example in Figure 20 shows the word feature typed into the Search Box and the 
ribbon that is dynamically created with commands that contain the text string. 

 

 
Figure 20 

 Clicking the “X” in the Search Box will remove the search ribbon and restore the previous ribbons. 
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Help 
Help Dialog 

 Pressing the F1 key will open a help dialog that contains Contents, Index and Search commands. 

 

 
 

Context Sensitive Help 
 Placing the cursor over any icon and pressing the F1 key will invoke help for that command. When a 

dialog is active; placing the cursor anywhere in the dialog and pressing F1 will invoke help for the 
command active in the dialog. 
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Data Types 
The application supports several data types including collected point data, polygon data and surface data.  
 
Point clouds are common data types which consist of individual point locations. The application can import 
several hardware device native file formats and also provides plug-ins for several hardware devices, enabling 
direct input of scan data into the application.  
 

Unordered Point Data 

 Unordered or raw point data is a collection of points, each having an X, Y, Z location. When viewed up 
close, unordered point data is semi-transparent.  

 Unordered point data may contain normal/vector information or not, point data which contains no 
normal information will be black in color, as shown in Figure 21. The same point data after shading is 
shown in Figure 22.  

 Shading point data enables a better view of the shape. When point data is shaded, the default color 
becomes light green in color. 

 Data collected using a scanner plug-in is automatically shaded. 

 
Shading can be applied to an unshaded point object in one of two ways: 

 Points > Repair > Shading > Shade Points 

 Points > Repair > Shading > Repair Normals 

 

 
Identifies an object in the Model Manager Panel as unordered point data. 

 

 
Figure 21 - Unshaded Point Data 

 
Figure 22 - Shaded Point Data 

 
  When using Repair Normals for the first time on an unshaded object, you may be presented with a continuation dialog 

box – this dialog should be answered ‘Yes’ if encountered to allow access to the entire command. 
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Ordered Point Data 

 Ordered point data is averaged into a cell/grid format and does not contain as many points as unordered 
point data. 

 Unlike unordered point data, you cannot see through a point cloud of ordered point data because of the 
cell structure. 

 Ordered point data spacing is always uniform with a grid like structure and is also green in color when 
viewed in the application. 

 Ordered point data has a different set of point tools than unordered point data. 

 When multiple ordered point data scans are combined into a single point object, the result is an 
unordered point cloud. 

 
Identifies an object in the Model Manager Panel as ordered point data. 

 
Figure 23 – Ordered (Cell) Point Data 

 
Figure 24 – Cells with Points Displayed 
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Polygon Data 
Polygon data is sometimes referred to as a mesh; triangles are formed by linking point data that result in a mesh. 
Polygon data comes from a variety of sources that include modeling software, scanning devices and a result of 
wrapping points in Geomagic Essentials.  

 When a polygonal object is generated the normal faces are colored blue by default, the back face or 
opposite side of the normal face is colored yellow.  

 If the mesh of a polygon object is modified, the underlying point structure will likewise be modified. 

 In the event that any polygon object normals are inverted either from other software or from the 
wrapping process in Geomagic Essentials, use Scan > Repair>Remesh > Flip Normals on the ribbon to 
reverse the orientation of normals.  

 
Identifies an object in the Model Manager Panel as polygon data. 

 
Figure 25 – Polygon Object Normals Correct 

 
Figure 26 – Polygon Object Normals Inverted 

Clicking the Display Panel tab and toggling on Edges in the Geometry Display roll-up group will reveal the mesh 
construct of any polygon object.  

An optimized mesh has a higher ratio of triangles in areas of high curvature to low curvature. An optimized mesh 
retains the proper shape description; see Figure 27 and Figure 28. 

 
Figure 27 – Uniform Mesh 

 
Figure 28 – Optimized Mesh 

A polygon object can also be changed into the point object.  

 
Scan > Convert > Convert to Points on the ribbon changes a polygon object into an unordered 
point object. 
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NURBS Data 
NURBS is a type of surface and is produced by the command AutoSurface. 

 NURBS is an acronym for Non Uniform Rational Bezier Spline. 

 A polygon object is required to create a NURBS structure in AutoSurface. 

 An object that has had NURBS based surfacing applied in AutoSurface is olive green in color. 

 An object that has had NURBS based surfacing applied in AutoSurface may be down converted to a 
polygon object. 

 

 Identifies an object in the Model Manager Panel as AutoSurface data. 

 
Figure 29 – NURBS data generated by AutoSurface 
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Curve Data 
Curve data is analogous to wireframe geometry; it can be either drawn directly or extracted from a model. 

Curve data has many properties: 

 Curves can be drawn manually. 

 Curves may be converted to Free Curves. 

 Curves may be converted to Boundaries. 

 Free Curves can be projected onto polygon models. 

 Curves may be defined by a section cut. 

 Free Curves may be saved in IGES format. 

 

 Identifies an object in the Model Manager Panel as 3D Curve data. 

 Identifies an object in the Model Manager Panel as 2D Curve data. 

 
Figure 30 – Curves 
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Scan Registration  
Overview 
The process of registration provides the ability to align scans with different coordinate systems. 
 

Manual Registration (1-Point) 
One point registration allows the user to align multiple scan objects using a single pick location that is common 
between the Fixed and the Float views in the same view orientation. 

ACTIVITY: Scan Registration (Unordered Point Data) 

Objective 
In this activity you will align scans of unordered point objects using Manual Registration, refine the alignment 
using Global Registration and combine the individual scans into a single object for more processing. The scan data 
used in this activity is typical of raw (unordered) point data scans of a part scanned in different set-ups. 

Commands 

 Manual Registration 

 Global Registration 

 Combine Point Objects 

Training File 
TR-01.wrp 

Open Data 

 

1. Open training file TR-01.wrp.  

 Click the Getting Started tab and select Open 
from the Tasks list. 

 Use the Open Files dialog to navigate to the 
folder where the training files reside. Select TR-
01.wrp in the Open Files dialog. 

 Click Open to open selected file. 

 Both scan objects should be active when the file 
is opened. If they are not active, make them 
active by CTRL+LMB clicking them in the Model 
Manager Panel.  

Figure 31 

 2. Click Points > Scan Registration > Manual Registration on the ribbon to start the 
Manual Registration command.  

 The Graphics Window will be divided into 3 view ports. The upper left view port is the Fixed view port and the 
upper right view port is the Floating view port. The wide frame at the bottom serves as a preview after 
registering the object in the Floating view port to the object in the Fixed view port. 

 3. Select the 1-Point Registration radio button in the Mode roll-up group if it is not 
already active. 
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 4. Define Fixed and Floating objects to align. 

 From the Fixed list in the Define Sets roll-up group, select Scan 001. The selected 
scan will turn red and appear in the Fixed view port (top left view).  

 From the Floating list in the Define Sets roll-up group, select Scan 002. The 
selected scan will turn green and appear in the Floating view port. (top right view) 

 The Fixed and Floating objects selected in the lists will appear in the Fixed and Floating frames similar to 
Figure 32. 

 There are two sides to each scan; always make sure you rotate the dark red and bright green sides of the 
scans towards you for registration. 

 

 
Figure 32 

 5. Orient Fixed and Floating views for selection. 

 Rotate each of the scans to the positions shown in Figure 33. 

 It is important that the Fixed and Floating view orientations be as close as possible to each other 
when using 1-Point Registration (default), otherwise the registration may not work correctly. 

 

 
Figure 33 
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 6. Pick a common point that is available in both the Fixed (red) and Floating (green) 
view ports, see Figure 34. 

 If you accidentally pick the wrong point, use the CTRL+Z keys to undo the last selection. 

 

 
Figure 34 

 7. When using 1-Point Registration; registration 
will start automatically when the second point is 
picked. If you have performed a successful 
registration the bottom window will update to show 
the aligned scans with overlapping data as shown 
in Figure 35. 

 Press the Register button to help refine the 
registration of the current scan. 

 If the scans are poorly aligned; either the view orientations were 
not close enough or you did not select registration points near 
enough to each other and need to try again. If this is the case, 
click the Unregister button in the dialog to move the scans back 
to their original positions and start the process again. 

 
Figure 35 

 8. When satisfied with the registration, accept the current registration and place the two 
scans into a group object if there is a checkmark in the Add to Group checkbox.  

 Click the Next button to accept the current registration. 

 In this example, please a checkmark in the Add to Group checkbox and use the default name of Group 1. 

 Click OK to exit the dialog.  

 9. You will notice in the Model Manager Panel that both scans have been placed in 
Group 1.  
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Global Registration 

 
1. Refine the registration (alignment) between the scan objects. 

 Click Points > Scan Registration > Global Registration on the ribbon. 

 Click Apply to start the registration process. 

 The registration process will stop when either convergence is detected or the maximum number of iterations 
has been reached. 

 2. After reviewing, click OK to accept the registration and exit the dialog. 

Combine Point Objects (Unordered Point Data) 

 

1. After registration, the scans are aligned but are still separate and need to be combined 
into a single point object. Verify that all scans are in a single Group in the Model 
Manager Panel and that Group is active. 

 Click Points > Combine > Combine Point Objects on the ribbon. 

 Name the point object to be created by typing “Model” in the Name field. 

 Accept the remaining default settings. 

 Click Apply. 

 Click OK to exit the dialog. 

 The point object is now ready for further processing. 

End of Activity 
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Registering Ordered Scan Data 
Ordered scan data contains cells, and depending on the scan angle, some cell data may be inaccurate and should 
be filtered out. The registration of ordered data scans is identical to that of unordered data but there are a few 
options when handling ordered data that will be covered in the next activity. 

ACTIVITY: Scan Registration (Ordered Point Data) 

Objective 
Align multiple, overlapping scans captured at different positions using the Manual Registration command. Refine 
the alignment using Global Registration and combine the individual scans into a single point object. Here is an 
overview of the steps to create a point object from unaligned ordered data scans: 

 Filter out poor cell data per scan that was collected using a poor capture angle. 

 Roughly align the scans to place them in the same orientation using manual registration. 

 Perform global registration to minimize the deviation between scans. 

 Remove overlapping cell data and combine the scans into a single point cloud for more processing. 

Commands 

 Filter 

 Manual Registration 

 Global Registration 

 Combine Point Objects 

Training File 
TR-02.wrp 

Open Data 

 

1. Open training file TR-02.wrp.  

 Click the Getting Started tab and select Open 
from the Tasks list. 

 Use the Open Files dialog to navigate to the 
folder where the training files reside. Select TR-
02.wrp in the Open Files dialog. 

 Click OK to open selected file. 

 These scans were taken with a scanner which outputs ordered 
data, meaning the point cloud is formatted in a grid-like 
arrangement.  

 
Figure 36 
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2. If all scan objects are not all highlighted at this 
time… highlight all of the scans in the Model 
Manager Panel by holding the CTRL key while 
LMB selecting each of them. 

 You can also perform a range selection by selecting the first 
object in the range, pressing the Shift key and selecting the 
last object on the range. 

 
Figure 37 

Filter Points 
 1. Remove cells whose normals are more than a specified degree from the scan direction. 

 Click Ordered Points > Repair > Filter on the ribbon. 

 Enter 72.0 into the Angle field. 

 Click Apply to start filter of data. 

 Click OK.  

 This command is only available when working with ordered (cell) data. 

Delete Stray Scan Data 

 

1. Automatically detect and remove small, undesired portions of the scan object. 

 Click Select > Data > Select By > Area on the ribbon.  

 In the dialog that appears, enter 2.0 in the Percent box.  

 Click Apply.  

 Several of the small segments will get selected. This command selects pieces of the scan that contain 
less than the specified percentage of that scan’s total area. 

 Click OK. 

 

2. The small segments are still selected so press the DEL key to remove them from the 
scan object. 

 

3. Now that the data has been filtered and edited, you can begin to align the scans. To 
align these six scans, first make sure they are selected in the Model Manager Panel.  

 Select Scan 001, press the Shift key and select Scan 006 to specify a range 
selection which will also activate the selected objects in the Model Manager Panel. 
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Manual Registration (n-Point) 

 
1. Click Points > Scan Registration > Manual Registration on the ribbon. This 

command allows you to roughly align multiple scans by picking areas where two scans 
overlap. 

 2. Select the n-Point Registration radio button in the Mode roll-up group 

 3. Define Fixed and Floating objects to align. 

 From the Fixed list in the Define Sets roll-up 
group, select Scan 001. The selected scan will 
turn red and appear in the Fixed view port. (top 
left view)  

 From the Floating list in the Define Sets roll-up 
group, select Scan 002. The selected scan will 
turn green and appear in the Floating view port. 
(upper right view) 

 The Fixed and Floating objects selected in the lists will appear in 
the Fixed and Floating frames similar to Figure 38 

 There are two sides to each scan; always make sure you rotate 
the dark red and bright green sides of the scans towards you for 
registration. 

Figure 38 

 4. n-Point Registration does not require exact view orientation like 1-Point 
Registration does. n-Point Registration requires a minimum of 3 points picked in 
each view.  

 Rotate each of the scans to positions similar to Figure 39 to see most of the 
overlapping data. 

 

 
Figure 39 
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 5. Pick the points as indicated in Figure 40 on both the Fixed (red) and Floating scans 
(green) at approximately the same locations on each.  

 If you accidentally pick the wrong location, press CTRL+Z to undo the last selection.  

 

 
Figure 40 

 6. A quick orientation of the scan data is done 
based on the points selected. 

 Click the Register button to start the 
registration process. 

 View the fitting of the 2 scans as shown 
in Figure 41. 

 If the two scans do not appear to be properly aligned 
but are pretty close, try clicking the Register button 
again to refine the fit.  

 If the scans still do not align, click the Unregister button 
to start again. 

 

 
Figure 41 

 7. When satisfied with your registration, click the Next button. This will accept the current 
registration and place the two scans into a group object if there is a checkmark in the 
Add to Group checkbox.  

 In this example, you will have a checkmark in the Add to Group checkbox and use 
the default name of Group 1. 

 You will notice that Group 1 is automatically created and highlighted in the Fixed list 
after clicking the Next button.  
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 As each Floating scan is registered, it will be removed from the Floating list and be 
placed in Group 1. 

 8. Leave Group 1 selected in the Fixed list and click Scan 003 in the Floating list to start 
the registration of the next scan.  

 Rotate the views as necessary to find the overlapping locations to make a selection on. 

 Select approximately the same 3 points in each view port. 

 Click the Register button.  

 9. Click Next after successfully registering this scan to add Scan 003 to Group 1. 

 10. Continue the previous process and register the 
remaining scans from the Floating list until all 
are aligned. 

 You will continue to rotate the views to 
locate and use the overlapping areas of the 
scans to register the remaining scans. 

 Once you have registered the last scan in the 
Floating list, all scans will be visible again.  

 Click OK to exit the dialog. 
 

 
Figure 42 

 
11. Look at the Model Manager Panel and you will notice that all scans have been placed 

into a Group.  

Global Registration 

 
1. Refine the registration (alignment) between the scan objects. 

 Click Points > Scan Registration > Global Registration on the ribbon. 

 Click Apply to start the registration process. 

 Several iterations of an alignment algorithm are run to better align the scans. Statistics will be reported in the 
dialog after each scan so the user knows the status of the current alignment.  

 The operation will terminate when one of three things happen:  

o The number of maximum iterations is performed. 

o A specified number of iterations are run without convergence.  

o When the command stops, the system will display the two scans with the greatest deviation in the 
Statistics group. 

 Pressing the ESC key at any time during the calculation will stop the command after the current iteration. 
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 2. Analyze the overlapping scan data to see how 
well the registration worked. 

 Click the Analysis icon in the Operations 
roll-up group. 

 Set the Density value to Full. 

 Click Compute.  

 Once the system is done processing, a colorized deviation 
map will display how each scan is related to its neighbor. 

 To speed the process up, set the Density value to 
something other than Full.  

 This is useful in reviewing the scans to see if one of the scans 
is causing the rest to be out of alignment. If so, then you can 
remove the errant scan from the group of scans and run the 
Global Registration again. 

 
Figure 43 

 3. Review each scan.  

 Select the Single Object radio button, and then use the arrow buttons to cycle 
through each scan. 

 After reviewing each scan, click OK to accept the registration. 

Combine Point Objects (Ordered Point Data) 

 

1. After registration, the scans are aligned but still separate and need to be combined into 
a single point object. Verify that all scans are in a single Group in the Model Manager 
Panel and that Group is active. 

 Click Ordered Points > Combine > Combine Point Objects on the ribbon. 

 Name point object to be created by typing “Model” in the Name field. 

 Check the Remove Overlap checkbox; this will remove overlapping scan data from 
the Ordered Data objects. This setting only applies to ordered data. 

 Notice the number of cells in the Overlay area of the Graphics Window. 

 Click Apply.  

 Click OK; the combined point object is created in the Model Manager Panel and the 
Group of scan objects has been deleted from the Model Manager Panel. 

 2. Remember that the source data for creating the combined point object was Ordered 
Data. Notice that the newly created combined point object is Unordered Data.  

 The new point object is now ready for further processing. 

 This is a good place to save your work in a typical workflow. 

End of Activity 
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Points 
Overview 
While a point object is active you have the opportunity to improve the scanned data. Noisy data can be improved, 
and point sampling techniques can be employed to reduce the density of point cloud data.  

All cleanup procedures are optional, but a “cleaned” point object can be converted to a polygon object with 
greater efficiency and higher quality. Sampling point objects also improves the computation times of other 
commands; it is very easy to capture more data than is necessary when scanning a part, more point data is not 
always “better”. 

Commands covered in this section include the following: 

 Select > Disconnected Components 

 Select  > Outliers 

 Reduce Noise 

 Uniform Sample 

 Wrap 

 

ACTIVITY: Point Data Processing 

Objective 
Improve and optimize a point object for other operations. 

Training File 
TR-03.wrp 

File Open 

 

1. Open training file TR-03.wrp.  

 
2. Change view to a previously saved user defined 

view. 

 In the Graphics Window, RMB click. 

 Select User-Defined Views > QuickView 1 
from the right-click menu to restore the view 
shown in Figure 44. 

 User-Defined Views can save any view orientation and are 
instantly available on the right-click menu as they are saved. 

 
Figure 44 
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Disconnected Components 

 

1. Scanned data often includes points that are isolated from the main point cloud; these 
types of points are referred to as disconnected components. You will now select these 
isolated points. 

 Click Points > Repair > Select > Disconnected Components on the ribbon. 

 Set the Separation parameter to Low; observe the number of points selected in the 
Overlay. 

 Set the Separation parameter to High; observe the number of points selected in the 
Overlay. 

 Set the Separation parameter back to Low. 

 A Low setting uses the smallest space between points that will find the most isolated points. The Medium and 
High settings will find fewer points as the size of the space between isolated points is increased. 

 2. Click OK to exit the dialog; the points detected remain selected. 

 
3. Press the DEL key to remove the selected (isolated) points. 

 

Outliers 

 

1. Outlier detection is based on a point to point relationship. The Select > Outliers 
command analyzes each point for proximity to neighboring points based on a sensitivity 
parameter, as sensitivity increases more outliers are detected and vice versa. 

 Click Points > Repair > Select > Outliers on the ribbon. 

 Click the Apply button to analyze the point object. 

 
 2. Change view orientation to review select points. 

Also notice the number of points selected in the 
Overlay, see Figure 45. 

 Rotate the point object and Zoom in/out to 
observe the points selected in the Graphics 
Window. 

 
Figure 45 

 

3. Adjust Sensitivity parameter to see how it impacts the number of points selected. 

 Change the Sensitivity to 70 and click Apply. Review Overlay information; notice 
the Selected Points value is lower. 

 Change the Sensitivity back to 85 and click Apply. 

 4. Click OK to exit the dialog; the points detected remain selected. 

 
5. Press the DEL key to remove the selected (outlying) points. 
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 6. It is not required to clean all outliers; however, it is good practice is to run this 
command a few times to get the most outlying points removed from the point object. 

 Click Points > Repair > Select > Outliers on the ribbon. 

 Use a Sensitivity value of 85. 

 Click Apply. Notice that fewer outliers have been detected the second time. Each 
time Select Outliers is used with the same Sensitivity value, fewer outliers will be 
selected. 

 7. Click OK to exit the dialog; the points detected remain selected. 

 8. Press the DEL key to remove the selected (outlying) points. 

 The Select Outliers and Delete commands are usually run in tandem, which makes them a good candidate for 
a Macro. 

 
Manual Editing 

  1. Zoom, pan and rotate as necessary to locate and manually delete any remaining stray 
points that may exist around the part perimeter.  

 See Figure 46 for an example of stray/errant points. 

 Try using different selection tools from the Right-Side Toolbar. 

 Remember that CTRL+LMB when using the selection tools, deselects.  

 
Figure 46 

 2. After selecting stray points, press the DEL key. 

 3. Continue to rotate, zoom, manually select and delete until you are satisfied that only 
points that describe the scanned part remain.  
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Reduce Noise 
 Reduce Noise is a powerful tool when used properly; if used improperly, it may introduce distortion into a 

scanned part. 

 

1. Click Points > Repair > Reduce Noise on the ribbon. 

 Reduce Noise is a form of compression that moves points closer together resulting in a smoother polygon 
object when the points are wrapped. 

 2. Rotate to the view shown in Figure 47. 
Using the defaults. 

 Click the Apply button. 

 Observe the information in the Statistics roll-up 
group. Staying alert to the Statistics roll-up group 
will help with assessing how much distortion is 
acceptable.  

 
Figure 47 

 3. Click on the Preview roll-up group to expand and activate the Preview command. 

 The cursor will change to a cross-hair shape. Click near the location shown in Figure 
48. 

 A polygon preview will be rendered at the area selected as shown in Figure 49. 
Zoom in to view the preview in greater detail. 

 

 
Figure 48 

 
Figure 49 
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 4. With the Preview roll-up group still expanded, move the Smoothness slider control in 
the Parameters roll-up group to a value of 2. As you move the slider, the preview will 
dynamically update to reflect your changes. 

 5. With the Preview roll-up group still expanded, change the reduction type in the 
Parameters roll-up group to Prismatic shapes (conservative) and observe how the 
preview changes. 

 Click the Preview roll-up group to collapse the group and deactivate the preview. 

 Rotate and Zoom to one or two other locations on the object and at each location; 
expand, select an area, preview that area and collapse the Preview roll-up group to 
deactivate it. 

 If the Preview roll-up group is still expanded and active, collapse the Preview roll-
up group at this time to deactivate it. 

 6. Click Apply to apply the previewed changes to the entire object. 

 Note changes of Maximum Distance in the Statistics roll-up group. If this were a high precision part, the 
amount of noise reduction applied may distort the scan data beyond the tolerance zone of the part. 

 7. In the Parameters roll-up group, enter a value of 0.5mm in the Deviation Limit 
field. 

 Click Apply; the scan will be updated with a limit on how far points can move.  

 Observe the Statistics roll-up group again; the Maximum Distance of any point moved will not exceed the 
value set in the Deviation Limit field. 

 Use the Deviation Limit parameter to limit the movement of scanned data. 

 8. Click on the Display Deviations roll-up group to expand and activate the Display 
Deviations command. 

 The display will change to a deviation map with a spectrum bar, see Figure 50. 

 Find the Max. Critical input field and change the value to 0.1 mm. Press the Enter 
key, the Min. Critical will automatically update to the inverse value. 

 Find the Max. Nominal input field and change the value to 0.01 mm. Press the 
Enter key, the Min. Nominal will automatically update to the inverse value. 

 The display will update the deviation color map and the spectrum bar, see Figure 51.  

 

 
Figure 50 

 
Figure 51 

 9. Click OK to exit the dialog. 
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Point Sampling 

 
1. Change the density of the point cloud without moving any points. 

 Click Points > Sample > Uniform on the ribbon. 

 Select the Absolute radio button in the Input roll-up group. 

 
 2. Orient view in order to see how sampling 

affects the point cloud. 

 Rotate and Zoom close to your point 
object, similar to Figure 52. 

 Note the current number of points in 
the Overlay.  

 Click Apply. 

 Note the change in the Overlay and 
the new density of the point object. 

 The default sample of Absolute is typically a 45% to 
65% reduction of points based on existing density of 
the point cloud.  

Figure 52 

 3. Adjust spacing parameter. 

 In the Input roll-up group, select the Define Spacing by Target radio button. 

 Change the value in the Points field to 80000. This sets a target of approximately 
80,000 points for the sample.  

 Click Apply and note the change in the Overlay and the new density of the point 
object. 

 4. Click OK to exit the dialog. 

 It is possible to over-sample a point cloud; ideally you want to improve the performance of a point 
cloud while maintaining its shape description.  
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Wrap 

 

1. Convert point object to a polygon mesh (STL) object.  

 Click Points > Wrap > Wrap on the ribbon. 

 You have already performed a managed noise reduction, locate Noise Reduction in 
the Settings roll-up group and set the drop-down list to None. 

 The Wrap command creates triangular faces by “connecting the dots” of a point cloud. The quality of a 
“wrapped” point object is dependent on the quality of the data it is derived from. Wrapping an unordered 
point object will produce approximately twice the number of triangles as there are points. The triangles in a 
polygon object are commonly referred to as a “mesh”. 

 2. Click OK to begin the Wrap operation. 

 When Wrap is applied to ordered point data; no dialog will appear – the point cloud will be wrapped 
automatically. 

 3. A polygon object is created and the point object it was created from remains in the 
Model Manager Panel. 

 

 
Figure 53 

End of Activity 
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Feature Objects 
Overview 
Features are 2D and 3D geometric objects created in the application. A feature object contains properties and can 
be “best fit” to polygon objects by applying them to selected regions. Feature objects can be used for a variety of 
commands, such as;  

 Export to neutral file format like STEP or IGES, which can then be imported into CAD/CAM applications.  

 Mesh re-fit and trimming 

 Alignment 

 Translation to polygon objects for Boolean operations 

Any feature may be edited, re-created from an edited selection set, deleted, and any feature property may be 
examined. Feature visibility may also be controlled and features may be renamed in the Model Manager Panel 
after creation. 

ACTIVITY: Best Fit Features 

Objective 
Create and edit features using best fit selection data on a polygon object. 

Training File 
TR-04.wrp 

Open Data File 

 

1. Use your choice of methods to access the Open command, navigate to the training 
files folder and open TR-04.wrp. 

 Zoom and Rotate the view to look at different portions of the polygon object in 
greater detail. 

 Select Isometric View from the Predefined View fly-out on the Right-Side 
Toolbar.  

 Select Fit Model to View on the Right-Side Toolbar or press CTRL+D, see 
Figure 54. 

 

 
Figure 54 
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Sphere Feature 
 1. Rotate the view to the side of the part with the 

open boundary hole, see Figure 55. 

 

 
Figure 55 

 2. Locate your mouse cursor towards the edge of 
the Graphics Area and press the MMB 

 Keep the cursor outside of the white circle as 
you move it around the perimeter of the white 
circle. This will cause the part to rotate parallel 
to the current view.  

 Rotate to the view to the position shown in 
Figure 56. 

 
Figure 56 

  

3. Select data for fitting. 

 Click the Select Through icon on the Right-
Side Toolbar. 

 Click the Rectangle Selection Tool icon. 

 Drag the rectangle to select the area shown in 
Figure 57. 

 Rotate to a new view, the spherical region of 
the part has been completely selected all the 
way through. 

 If the spherical region was not selected all the way through – 
check that Select Backfaces Mode is active and try again. 

 
Figure 57 
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4. Click Model > Create > Sphere > Best Fit on 
the ribbon. 

 The Sphere will be fitted to the selected 
region in Figure 58. 

 The selected area determines the overall size of any best fit 
feature. Select areas without distortion if possible, the more 
area selected, the better the fitting process will be. 

 
Figure 58 

 5. Click Apply. 

 The feature is created with the selected 
region. See Figure 59. 

 Click Next to accept the feature.  

 You could continue to create additional Sphere features at 
this time. 

 Click OK; this will create a new sub-node 
folder on the Model Manager Panel under 
the active object called Features. This sub-
node will contain the newly created sphere 
feature.  

Figure 59 

Feature Properties 
 1. In the Model Manager Panel; expand the current active object node by clicking on 

the “+” symbol next to it. 

 A Features sub-node is created with the first feature created on any object. 
Expand the Features node, the Sphere feature just created will appear on the 
tree. 

 RMB click on the Sphere feature, a right-click menu will appear.  

 2. Click Select Entities; the selection set used to make the Sphere feature will be 
displayed. 

 Press CTRL+C to clear the selection set. 

 3. RMB click on the Sphere feature, a right-click menu will appear. 

 Click Properties from the menu. A properties dialog containing geometric 
information about the feature will be displayed. Review the information in the 
Parameters roll-up group and Fitting Statistics roll-up group. 

 Click OK to exit the dialog. 
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 4. RMB click on the Sphere feature and notice other options on the menu including 
Export. 

 Any feature may be exported to a neutral file format by this menu option. 

 Other common options include Rename, Delete, and Edit… on this menu. 

 Click anywhere other than the menu to clear the menu from the display. 

Cone Feature 

 

1. Make the selection on the conical region in the 
same way as you did with the Sphere; review the 
Sphere steps for reference. The selected region 
should appear as shown in Figure 60. 

 Click Model > Create > Cone > Best Fit on 
the ribbon. 

 Click Apply to create the feature. 

 Click OK to exit the dialog. 

 
Figure 60 

Cylinder Feature 

 

1. Rotate and Zoom to the view shown in Figure 
61. 

 Click Model > Create > Cylinder > Best Fit 
on the ribbon. 

 Click Select Visible icon on the Right-Side 
Toolbar. 

 Click the Paint Brush Selection Tool icon on 
the Right-Side Toolbar. 

 RMB click in the Graphics Window and select 
Set Rotation Center from the right-click 
menu. Click near the edge of cylinder bore; 
this will make rotation easier while making a 
cylindrical selection. 

 
Figure 61 



  
 

Copyright © 2019 3D Systems 52 Geomagic Essentials® 

 

 2. Select around the distorted areas as shown in 
Figure 62. Continue to select/rotate to gather 
as much cylindrical information for the fitting 
process as you can. Feel free to use other 
selection tools of your choice. 

 Avoid selecting data into the round and fillet areas at the 
top/bottom of the cylindrical face. If you select something 
accidentally, you can use CTRL+LMB and deselect to refine your 
cylindrical region. 

 
Figure 62 

 3. Click Apply to create the Cylinder feature. 

 4. Click OK to exit the dialog. 

 You now have three features as shown in Figure 63. Observe the features in the 
Model Manager Panel. 

 

 
Figure 63 

 
5. Modifying existing features via the Model Manager Panel. 

 RMB click on the Cylinder feature in the Model Manager Panel, a right-click 
menu will appear. 

 Select Edit … from the right-click menu. The Edit Feature dialog is displayed. 

6. In Parameters roll-up group, the Direction (axial) information can be reversed. 

 Click the Flip button. The cylinder axis direction will be reversed. Arrowhead is now 
visible. 

 7. Change the height of the cylinder by modifying the geometric information of the 
active feature. 

 In the Parameters roll-up group, change the Height parameter to 1.5 in and 
press Enter, the cylinder feature will update in the Graphics Window. 

 Click the OK button. 
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Plane Feature 

 

1. After creating several features, they may start to clutter the display. 

 Click Model > Display > Feature Visibility > Toggle All Features on the ribbon 
or click the Toggle All Features icon on the Right-Side Toolbar to hide all 
features. 

 Clicking the Toggle All Features icon again will show all features. 

 Pressing F9, performs the same operation. 

 Individual feature visibility may also be controlled by RMB click; Hide/Show in the Model Manager Panel or 
from the Feature Visibility stack on the ribbon. 

 

2. Rotate to the view and make the selection shown 
in Figure 64. 

 Click Model > Create > Plane > Best Fit on 
the ribbon. 

 Click Apply to create the Plane feature. 

 
Figure 64 

 3. Click the Deviations roll-up group to activate the 
Deviation sub command. 

 Note the areas of highest deviation (red) in the color map that is 
applied to the selected region in Figure 65.This information 
shows the areas of highest deviation based on the selected area 
to “best fit” the feature to. Best Fit is dependent on the selection 
you make, and all data selected will be used in the fitting 
process. 

 In the Statistics roll-up group, note the Maximum Distance 
information.  

 
Figure 65 

 4. Close the Deviations roll-up group up by clicking on the title of the roll-up group 
again; this will deactivate the Deviation display. 
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 5. Press the CTRL key while you deselect the areas 
shown in Figure 66. 

 Click Apply to update the feature to the edited 
selection data. 

 
Figure 66 

 6. Click the Deviations roll-up group and note the 
change in the Maximum Distance section of the 
Statistics roll-up group.  

 The new display and information should reflect less deviation in 
the fitted feature as shown in Figure 67. 

 Click the Deviations roll-up group to 
deactivate the Deviation display. 

 
Figure 67 

 7. In the Name field, edit the name to Back Plane. 

 Click Apply, the name of the Plane will update in the display. 

 Click Next; this will keep you in the Create Plane dialog and enable you to create 
additional Best Fit planes. 

 8. Make selections and Name the planes as shown in Figure 68 to Figure 70. Click 
Apply to create and Next to move to the creation of the next plane feature.  

 

 
Figure 68 

 
Figure 69 

 
Figure 70 
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 9. After creating all of the plane features, click OK to exit the Create Plane dialog. 

 When creating the same type of feature, clicking Next will keep you in the create features environment to 
create multiple features. 

Circle Feature 
 1. Zoom and rotate to the view shown in Figure 

71. 

 Click Model > Create > Circle > Natural 
Boundary on the ribbon. 

 Click the Toggle All Features icon on the 
Right-Side Toolbar to hide all features. 

 
Figure 71 

 2. Select the boundary of the hole; a Circle feature 
will be best fit to the boundary. 

 Click Apply. 

 Click Next, to accept the feature. 

 Click OK to exit the dialog. 

 See Figure 72. 

 
Figure 72 

 

3. Click Model > Edit > Edit Features on the 
ribbon. 

 Select Circle from the Filter drop-down list in 
the Features roll-up group. 

 Select Circle 1 from the Name drop-down list 
in the Features roll-up group. 

 In the Parameters roll-up group, change the 
Diameter value to 1.125 in and press Enter, 
see Figure 73. 

 Click OK to exit the dialog. 

 Any feature may have its properties edited using the Edit 
Features command. 

 
Figure 73 

End of Activity 
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Alignment 
Feature objects have many uses including aligning a data object to the World Coordinate System (World CSYS). 
Having data aligned to the World CSYS will make many commands easier to use. 

ACTIVITY: Align to World Coordinate System 

Objective 
Align a data object to the World CSYS using Features.  

Training File 
TR-05.wrp 

Open Data File 

 

1. Use your choice of methods to access the Open command. 

 Navigate to the training files folder and open TR-05.wrp. 

 Select Fit Model to View on the Right-Side Toolbar or press CTRL+D, rotate 
model to the view shown in Figure 74. 

 

 
Figure 74 

 2. Features are required to use the Align to World command. Features that may be 
used world alignments are: 

 Planar alignments: Planes, Rectangular Slot and Circle features. 

 Axial alignments: Line, Cylinder and Cone features. 

 Point alignment: Point features. 
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Align to World 

 1. Click Isometric View on the Right-Side Toolbar. 

 2. Setting the View to Isometric is an easy way to 
identify where and how you want to align your 
model, Figure 75 illustrates the position of 
system planes relative to the Isometric view. 

 The three system planes create a corner of a virtual box; you 
will be placing the data object in the box. 

 
Figure 75 

 
3. Click Tools > Object Alignment > Align To World on the ribbon. 

 In the Inputs roll-up group, select the XY Plane from the Fixed: World list. 

 Select the Bottom Plane from the Float: Data Object Name list. 

 Click on Create Pair, the feature plane named Bottom Plane and the world XY 
Plane, will appear in the Pairs roll-up group list and update the Statistics roll-up 
group, see Figure 76. 

 

 
Figure 76 
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 4. In the Inputs roll-up group, select the YZ Plane from the Fixed: World list. 

 Select the Side Plane from the Float list. 

 Click on Create Pair, the alignment will add a subsequent pair in weighted 
descending order to the Pairs roll-up group list. Any misalignment of the Side 
Plane will be displayed as a deviation in the Statistics roll-up group. 

 In this case the Side Plane orients the object in the wrong direction, use the Flip 
Plane button to the right of the Pairs list to reverse the normal direction of the 
Side Plane. 

 5. Create another pair from the XZ Plane and the Back Plane. 

 View the information displayed in the Statistics roll-up group, note that the object is fully constrained with no 
degrees of freedom still remaining. 

 Click OK to accept the alignment and exit the dialog. 

Create a Point of Origin 
 1. To locate a specific location at the World CSYS Origin of 0, 0, 0 – a Point feature 

must be created and added to the alignment process. 

 Click Model > Create > Point > 3 Planes on the ribbon.  

 In the Name field, change the default name to New Origin. 

 For Plane 1: Select the Back Plane in the Graphics Window. 

 For Plane 2: Select the Side Plane in the Graphics Window. 

 For Plane 3: Select the Bottom Plane from the drop-down list. 

 2. Click Apply to create the point feature. 

 Click OK to exit the dialog. 

 
3. Click Tools > Object Alignment > Align To World on the ribbon.  

 In the Inputs roll-up group, select Origin from the Fixed: World list. 

 Select New Origin from the Float list. 

 Click on the Create Pair button, the pairs are added to the Pairs roll-up group list.  

 Create a pair using the XY Plane and the Bottom Plane. 

 Create a pair using the YZ Plane and the Side Plane. 

 The point feature is now located at 0,0,0 of the World Coordinate System. 

 4. Click OK to exit the dialog. 

 5. Click through the Predefined Views on the Right-Side Toolbar. 

 6. To make this alignment permanent. 

 Click Tools > Move > Reorient Model on the ribbon. 

 Click the OK button to confirm you want this orientation to be a permanent change. 

End of Activity 
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Polygon Objects 
Overview 
A polygon model or mesh is a collection of triangles; vertices are where these triangles meet, and the vertices are 
the same as the underlying point object. If the polygon structure changes, so does the underlying point structure. 

An STL file type is synonymous with a polygon model; they are one and the same. An exported STL file can be read 
by many rapid prototyping, CAD/CAE, and multi-media applications. In some cases, perfecting the polygon model 
is all that is required. Likewise, many applications can produce STL files and they can be imported to for further 
processing, surfacing and/or comparisons. Several hardware scanner vendors also produce an STL file as a means 
of file sharing with external applications. 

There are many tools available in polygon mode; from minor touch-up to mesh repair, mesh restructure, 
deformation, Boolean modeling and curve extraction.  

A quality polygon object is also essential for applying CAD or NURBS surfaces, and many of the commands covered 
in this chapter also serve as a precursor to surfacing. This chapter is designed to introduce you to commonly used 
commands that improve the quality of a polygon object. 

ACTIVITY: Level I 

Objective 
Learn how to repair a polygon object.  

 

Commands covered in this section include the following: 

 Make Manifold (Open) 

 Remove Spikes 

 Mesh Doctor 

 Reduce Noise 

 Fill Holes 

Training File 
TR-05.wrp 
 

File Open 

 

1. Open training file TR-06.wrp. 

 Navigate to the training files folder and open TR-06.wrp. 

 Zoom and Rotate the view to look at different portions of the polygon object in 
greater detail. 

 Select Right View from the Predefined View fly-out on the Right-Side Toolbar.  

 Select Fit Model to View on the Right-Side Toolbar, see Figure 77. 
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Figure 77 

 2. RMB click on Fairing in the Model Manager Panel and select Duplicate from the 
right-click menu. 

 A copy of the polygon object will be created in the Model Manager Panel and will automatically be set as 
active. 

Manual Editing 

 

1. Click Select Backfaces Mode on the Right-Side Toolbar to turn it OFF and prevent 
selecting triangles on the other side of the object. 

 Zoom/Rotate/Pan as necessary. Using the selection tools on the Right-Side 
Toolbar. Make the selections shown in Figure 78 to Figure 80 and Delete them. 
Leave the strip of triangles at the top of the selected area in Figure 79. 

 Manual selection and deletion of poor triangles that affect the mesh will make other repairs easier and more 
effective.  
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Figure 78 

 
Figure 79 

 
Figure 80 

Floating Triangles 

 
1. Click Scan > Repair > Manifold > Make Manifold (Open) on the ribbon. 

 The Make Manifold command located and automatically deleted the floating triangles. Triangles that are not 
connected by edges to the main mesh are considered non-manifold. Removal occurs without a dialog. 

Reduce Noise 

 

1. Click Scan > Smooth > Reduce Noise on the ribbon. 

 Set the type of reduction to Prismatic shapes (aggressive). 

 Set the Smoothness Level slider to 3. 

 Set the Deviation Limit in the Parameters roll-up group to 0.3 mm. 

 Click Apply. 

 Noise reduction can be applied to smooth the mesh of this object. Using the Deviation Limit parameter is 
essential to keeping a polygon model within a presumed tolerance. 
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 2. View the object from different viewpoints using zoom and rotate. 

 Click OK to accept the noise reduction. 

 The fairing should appear similar to Figure 81. 

 Change the light source using ALT+LMB for a better view. 

 

 
Figure 81 

Mesh Doctor 

 
1. Click Scan > Repair > Mesh Doctor on the ribbon.  

 The Mesh Doctor detects a wide variety of mesh issues and provides numerous methods for resolving them. 
Mesh Doctor will not analyze a pre-selection; the entire mesh will always be analyzed. 

 With Auto-Repair selected in the Type group, remove the checkmark from the 
Small Holes checkbox and place a checkmark in the Small Tunnels checkbox in the 
Analysis roll-up group.  

 Click the Apply button. 

 We turned off the Small Holes check so we can control filling with the Fill Holes command. 

 Mesh Doctor will perform the repairs selected in the Analysis roll-up group. 

 2. Click OK once repairs are complete. 

 The Advanced roll-up group of the Mesh Doctor contains the parameters used in mesh analysis. 
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Filling Holes 

 
 

1. There are two ways to fill holes; Fill All and Fill Single. Fill All finds all boundaries 
and does as the name implies. Fill Single interacts with each hole; you can also 
change either/both the Technique and Mode as desired in Fill Single mode. 

  Fill Techniques control the curvature of a fill. 

 Curvature filling starts tangent to edges and ends tangent based 
on curve projection. 

 Tangent filling starts tangent to edges and projects a flattened 
curve. 

 Flat filling is as the name indicates. 

 Fill Modes control the way a hole fill occurs. 

 Complete fills a closed boundary. 

 Partial fills between two selected points and an included 
boundary. 

 Bridge fills from selected triangles edges to selected triangle 
edges. 

 
Figure 82 

Fill Single 

 
 
 

1. Click Scan > Fill Holes > Fill Single on the ribbon. 

 Verify that Curvature technique and Complete mode are active. 

 2. Rotate the view as shown in Figure 83. 

 Hover the cursor over the boundary. It will turn 
red. 

 LMB click the red boundary and the hole will be 
filled. 

 
Figure 83 

Fill Techniques 

Fill Modes 
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 1. Rotate the view to the other end and locate the 
hole shown in Figure 84. 

 Hover the cursor over the boundary, it will turn 
red. 

 LMB click the red boundary and the hole will be 
filled. 

 Filled holes are shown in red, in the Fill Hole 
group, toggle Show Fill off to see the hole as it 
will appear once you exit hole filling. Toggle 
Show Fill back on. 

 
Figure 84 

 2. Rotate and Zoom to the view shown in Figure 85 
at the upper right corner where you deleted 
triangles earlier. 

 Hover the cursor over the boundary, and LMB 
click; the hole will be filled. 

 This is not a good fill, press CTRL+Z to undo the 
fill. 

 You can CTRL+Z to undo any fill, the limit that may be undone is 
10. 

 Select Tangent as the Fill Technique on the 
ribbon. This will keep the filled curve from 
projecting too far. 

 Hover over the boundary again and LMB click; 
the hole will be filled.  

Figure 85 

 3. Rotate and Zoom the view to the lower right 
corner where you deleted triangles earlier. 

 Select Partial as the Fill Mode on the ribbon. 

 As you hover near the corner of the cut-out, a 
red dot will appear as shown in Figure 86. 

 LMB click at this corner, this locates the 1ST 
point on the boundary. 

 
Figure 86 
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 4. As you move the cursor to the other corner, the 
boundary area to fill will dynamically highlight in 
red. The red dot will snap to triangle vertices as 
you move over them. 

 Place the cursor at the other corner of the cut-
out as shown in Figure 87. 

 LMB click at this corner, this locates the 2ND 
point on the boundary. 

 
Figure 87 

 5. Hover the cursor in the red bounded area as 
shown in Figure 88. 

 LMB click in this area or on the boundary to 
apply the fill to the area outlined in red. 

 
Figure 88 

 6. You are still in Fill Single/Partial mode; select the Curvature technique on the 
ribbon. 
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 7. Rotate/Zoom the view as shown in Figure 89. 

 While in filling mode a different right-click menu is available. RMB click in the 
Graphics Window. 

 From the right-click menu click Select Triangles; you are placed in selection 
mode; using your selection tools, select triangles as shown in Figure 89. 

 Hole filling re-builds curvature better when the hole boundary is a rectangular in shape. 

 

 
Figure 89 

 8. Press the DEL key to remove the selected areas. 

 9. RMB click in the Graphics Window again and select Fill from the right-click menu. 

 Select the top left corner for the 1ST point and the top right corner as the 2ND point 
to create the boundary shown in Figure 90. 

 Pressing the ESC key after points are selected in a partial fill mode will deselect the points to start a partial fill 
over. 

 Click on the red boundary to complete the partial fill. 

 

 
Figure 90 

 10. RMB to bring up the Fill Holes editing commands. 

 Click Select Triangles from the right-click menu. 
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 11. Locate and navigate as necessary to make the selections shown in Figure 91. 

 

 
Figure 91 

 

12. After making the selections, press the DEL key to remove the selected triangles. 

 13. Floating triangles are uncovered in the areas where you made your selections. You can 
remove floating data while still in the Fill Single command. 

 RMB click to bring up the right-click menu hole editing commands again and click 
on Delete Floating Data. All floating triangles will be removed. 

 RMB click again and select Fill from the right-click menu. 

 

14. On the ribbon, select Complete mode and verify that the Curvature technique is 
selected. 

 15. Move the cursor over a boundary in each area where the selected triangles were 
deleted and click each boundary to fill each hole. 

 16. You have completed filling single closed and partial holes; it is time to switch to Fill All 
for the remaining holes. 

 Click the Fill Single icon on the ribbon to exit the command. 
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Fill All 

 

1. Click Scan > Fill Holes > Fill All on the ribbon. The Fill All dialog will start and the 
number of Selected Holes will be displayed in the Overlay of the Graphics Window. 

 There are several small holes scattered throughout the mesh, the Fill All command can be used for these 
smaller holes. 

 Notice that ALL boundaries are counted, including the entire outside perimeter of this object. 

 In the Hole Selection roll-up group, click the up arrow at the right side of the list 
next to Deselect Largest. The largest boundary is deselected; notice that Selected 
Holes changed in the Overlay. 

 Click the up arrow again. The next largest boundary (air duct) will be deselected and 
removed from the count in the Overlay. 

 2. Locate the holes in Figure 92; the boundaries are red, which means they will be filled 
if not deselected. Hover the cursor over one of them; hold the CTRL key down while 
you LMB click the boundary.  

 The hole boundary will be deselected and removed from the hole count, perform the 
same operation on the other hole shown in Figure 92. 

 

 
Figure 92 

 
3. Select Right View from the Predefined View fly-out on the Right-Side Toolbar.  
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 4. Zoom to the area with the small holes shown in Figure 93. In the Hole Selection 
roll-up group of the Fill All dialog toggle on the Maximum Circumference parameter 
by placing a check in the checkbox. The numeric field below it will become active. 

 In the Overlay, Hole Circumference information is displayed when the Maximum Circumference parameter is 
activated. 

 Cursor over a few holes, you will see the information change dynamically as you 
pass over a hole boundary. 

 Hover the cursor over the hole shown in Figure 94 and LMB click the boundary. 

 The Maximum Circumference parameter updates to the size of the selected boundary and only holes smaller 
than the selected hole will remain highlighted in red. The Selected Holes information in the Overlay will also 
update. 

 Any hole boundaries of the same or less size than the number entered into this field will be excluded from the 
Fill All operation. 

 

 
Figure 93 

 
Figure 94 

 5. Click Apply in the Fill All dialog to fill the Selected Holes. 

 6. Toggle the Maximum Circumference parameter off in the Fill All dialog, the 
remaining holes will again be selected. 

 7. Click Apply to fill all remaining holes. 

 8. Click OK to exit the dialog. 
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Checking the Mesh 

 

1. Click Scan > Repair > Mesh Doctor on the ribbon.  

 Click Apply to resolve any errors found. 

 Click OK to exit the dialog. 

 After repair operations that affect the mesh like hole filling, it is a good practice to run the Mesh Doctor to 
check the mesh.  

 2. Zoom, Pan and Rotate the fairing, it should look similar to Figure 95. 

 

 
Figure 95 

 
 

3. This is a good time to save your work. Click the Application Button at the top left of 
the application and select Save As from the application menu. 

 Navigate to the Desktop in the Save As dialog and change the File name to 
Fairing. 

 Click the Save button. 

End of Activity 
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ACTVITY:  Level II 

Objective 
Apply additional repair/smoothing, trimming, boundary editing, decimation and deviation analysis commands.  
 
Commands covered in this section include the following: 

 Fill Single 

 Defeature 

 Sandpaper 

 Relax 

 Modify > Create/Fit Hole 

 Move > Extrude Boundary 

 Move > Project Boundary to Plane 

 Trim > Trim with Plane 

 Decimate 

Training File 
TR-07.wrp 

File Open 

 
1. Navigate to the training files folder and open TR-

07.wrp. 

 Zoom and Rotate the view to look at different 
portions of the polygon object in greater detail. 

 Select Isometric View from the Predefined 
View fly-out on the Right-Side Toolbar.  

 Select Fit Model to View on the Right-Side 
Toolbar, see Figure 96. 
 

 
Figure 96 
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Fill Single 

 

1. Rotate the object and locate the hole shown in 
Figure 97.  

 Click Scan > Fill Holes > Fill Single on the 
ribbon.  

 Select Curvature as the fill technique and 
Complete as the fill mode. 

 Cursor to the hole, when it highlights in red, 
click the edge to fill it. 

 Click the Fill Single button again to exit the Fill 
Single method. 

 
Figure 97 

 2. Press CTRL+D to fit the view. 

Sandpaper 

 
1. Click Scan > Smooth > Sandpaper on the ribbon. 

2. Under the Operation roll-up group select the QuickSmooth radio button. Adjust the 
Strength slider to 0 (Min.) 

3. Place your cursor over one of the rough areas shown in Figure 98, press and hold the 
LMB. A circular cursor will appear, indicating smoothing is active. Move the cursor back 
and forth over the areas as if you were rubbing your thumb over a clay model. Smooth 
as necessary. 

 The cursor changes in size based on the underlying mesh density.  

 

 
Figure 98 

 4. Try to find other small areas of the object that could use some smoothing, experiment 
with the Relax parameter and the Strength slider. Move to the next step when you 
are done. 
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 5. Click OK to exit the dialog. 

 If you don’t like the appearance, you can click Reset while in the command to restore the object back to its 
original state. 

Defeature 

 
1. Zoom in on the side of the joystick embossed with the words “Made in USA”. From the 

Right-Side Toolbar, click the Custom Region Selection Tool.  

 Click a series of points around the words, as shown in Figure 99. A white line will 
appear through the points you pick. To close the loop, either press the spacebar, or 
click the RMB. Once the loop is closed, all connecting triangles in the area will be 
selected. 

 

 
Figure 99 - Before 

 
Figure 100 - After 

 
2. With the area selected, click Scan > Repair > Defeature on the ribbon. The selected 

area is removed, as shown in Figure 100. The Defeature command is useful for 
removing unwanted features of the model. 

 Defeature deletes the selected area and performs a curvature-based hole fill. 

Mesh Maintenance 
 1. At this stage in the activity, the polygon object should be ‘watertight’.  

 Click Tools > Measure > Compute > Compute Volume to check the volume of 
the active object. If you get a value of zero, there is a hole somewhere in the mesh; 
otherwise, this object is a completely closed volume. 

 A closed volume object is required for rapid prototype printing or SLA processing. 

2. If the object is not closed, locate the hole(s) and fill them. 

 
3. Click Scan > Repair > Mesh Doctor on the ribbon. 

 Click Apply if any errors in the mesh are found. 

 Click OK to exit the dialog. 

 After all repairs that affect or change the mesh are completed, it is a good practice to check the mesh for any 
errors that may exist. 

 The constrained boundaries left by the Extrude Boundary and Trim with Plane commands will ‘hold’ the edges 
they are on to prevent spike removal from rounding them off. 



  
 

Copyright © 2019 3D Systems 74 Geomagic Essentials® 

 

Decimate 

 

1. Click Scan > Repair > Decimate on the ribbon. 

 Meshes that have undergone extensive repairs or are very dense can benefit from decimation. Decimation is 
the process of triangle reduction, when performed, it also reorganizes the mesh.  

 Decimation can also aid with smoothing an object in areas of low curvature. 

 2. To view the effect of Decimate on the mesh. 

 Click the Display Panel tab. 

 Locate the Geometry Display roll-up group. 

 Place a checkmark in the Edges checkbox. 

 Zoom to an area that contains high and low 
curvature similar to Figure 101. 

 Click the Dialog Panel tab to return to the 
Decimate command. 

 
Figure 101 

 3. In the Reduce to Percentage parameter field, enter a value of 40.0 and press Enter; 
the Target Triangle Count will update. 

 A percentage or triangle count can be specified for the amount of decimation. 

 Place a checkmark in the Fix Boundaries checkbox to protect triangle structure 
where boundaries are located. 

 At this time the Curvature Priority, Mesh Priority and Maximum Aspect Ratio 
checkboxes in the Advanced roll-up group should be cleared (off).  

 4. Click the Apply button, after a few moments the 
mesh will redraw and appear similar to Figure 
102. 

 Note the reduction of triangles in the Overlay. 

 A specific area may be decimated by pre-selection before 
performing entering this command.  

 Some curvature protection is always present, especially on an 
object with areas of high curvature such as this one. On meshes 
that have little or no areas of high curvature, a uniform mesh will 
result. 

 
Figure 102 
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 5. Click the Reset button at the bottom of the dialog. 

 Enter a value of 40.0 in the Reduce to 
Percentage parameter field. 

 Place a checkmark in the Curvature Priority 
checkbox in the Advanced roll-up group. 

 Set the slider control for Curvature Priority to 
3. 

 Click Apply, the mesh will redraw similar to 
Figure 103. 

 Notice a higher triangle density in the areas of high curvature.  
 

Figure 103 

 6. Click the Reset button at the bottom of the dialog. 

 Enter a value of 40.0 in the Reduce to 
Percentage parameter field. 

 Place a checkmark in the Mesh Priority 
checkbox in the Advanced roll-up group. 

 Set the slider control for Mesh Priority to 3. 

 Click Apply, the mesh will redraw similar to 
Figure 104. 

 
Figure 104 

 7. Change the Reduce to Percentage value to 30.0. 

 Click Apply. Note the triangle count in the 
Overlay. 

 From the Right-Side Toolbar click Fit Model to 
View. 

 Rotate model as shown in Figure 105, observe 
the reorganization of the mesh. 

 Take care not to over-decimate, areas of high curvature 
can become faceted and distort the captured information. 

 
Figure 105 
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 8. Click the Display Panel tab. 

 Locate the Geometry Display roll-up group. 

 Remove the checkmark in the checkbox next to 
Edges. The display of triangle edges will be 
turned off, see Figure 106. 

 Click the Dialog Panel tab to return to the 
Decimate command. 

 Click OK to exit the dialog. 

 
Figure 106 

 
Decimation decreases the computation time of surfacing and should be done (if necessary) as a final 
step prior to surfacing a part.  

Large triangles make hole filling, extrusions, etc. difficult to work with. If a part is already highly 
decimated in areas that need these types of repairs; the Refine command performs the opposite 
effect on the mesh, subdividing triangles. 

End of Activity 
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Exact Surfaces 
Overview 
An Exact Surface is a collection of smaller bounded quadrangular patches. A polygon object intended for Exact 
Surfacing can be an open or a closed volume object.  Quadrilateral patches are arranged in a layout appropriate 
to represent the shape.  A multiple resolution grid structure is laid on each patch, and a NURBS surface is fit to 
each patch. Automatic UV parameterization with global connectivity and G1 continuity is guaranteed across 
adjacent patches. Tangent continuity is achieved across all patch boundaries and corners unless specified 
otherwise by the user.  The NURBS surface can be exported as an IGES or STEP file, and imported into any 
CAD/CAM or visualization system. 

Good Patch Structure 
Most important in producing a satisfactory NURBS surface object is obtaining a good patch structure. The ideal 
structure is: 

 Regular:  Each patch is approximately rectangular with vertices of degree four. 
 Shape appropriate: There are no severe or multiple curvature changes (bumps or holes) in the interior of 

a patch. 
 Efficient:  The model contains close to the minimal number of patches consistent with the first two 

requirements. 

ACTIVITY: AutoSurface 

Objective 
Learn how to use AutoSurface and discover the components that make up the NURBS control network. 

Training File 
TR-08.wrp 

Open Data 

 
1. Use your choice of methods to access the Open 

command. 

 Navigate to the training files folder and open 
TR-08.wrp, see Figure 107. 

 
Figure 107 
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AutoSurface 

 

2. Click Model > AutoSurface > Start AutoSurfacing on the ribbon. 

 The Entering Exact Surfaces dialog will appear with the option to Create New 
Patch Layout selected.  

 Click OK to continue to Exact Surfacing. 

 After Exact Surfacing initializes, the Model Manager Panel icon for the object to be surfaced will change to 
an hour glass shape, indicating that is it now a an Exact Surface object. 

 3. Click Model > AutoSurface > AutoSurface on the ribbon. 

 In the Geometry Type roll-up group, select the Mechanical radio button. 

 In the Patch Count roll-up group, select the AutoEstimate radio button. 

 In the Surface Detail roll-up group, place the slider control at 2. 

 In the Surface Fitting roll-up group, select Constant and remove the checkmark 
from the Merge patches automatically checkbox. 

4. In the Options roll-up group, set the checkboxes as follows: Sharpen all 
constrained contours = On, Extend contour lines = Off, Interactive mode = 
Off. 

 5. Click Apply to begin the surfacing process. 

 After a few moments, the object in the display will update to an Olive color, the object now has a NURBS 
surface applied to it, see Figure 108. 

 Click OK to exit the dialog. 

 

 
Figure 108 – NURBS Surfaces 

End of Activity 
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Deviation Analysis 
 1. To perform a deviation analysis of a fitted surface, click Tools > Compare > 

Deviation on the ribbon. 

 In the Spectrum roll-up group, set the values for Max/Min Critical to 0.1/-0.1 mm 
and the values for Max/Min Nominal to 0.05/-0.05.  

 Click Apply to generate a deviation spectrum anaylsis, see Figure 109 

 

 
Figure 109 

 2. Observe the deviation map and spectrum, note that the Constant fitted surface is has 
less deviation than the Adaptive fitted surface from the surface fitting section of this 
activity. 

 Click OK to exit the dialog. 

Exporting the NURBS Surfaces 
 1. Once you have applied a NURBS surface to the model, you can export this surface data 

to your CAE system. Right-click on the surfaced object in the Model Manager Panel. 

 Select Save… from the right-click menu. 

 2. Navigate to the Desktop in the Save As dialog. 

 Enter a new File name: cad-data 

 Select IGES File (*.igs; *.iges) from the Save as type drop-down list. 

 Click Save. 

 Click Ok when the Export Options dialog appears. The IGES file will be written to 
the desktop and ready for import into another CAE application. 

End of Activity 
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Curves 
Overview 
Curves may be drawn directly on polygon models and converted to free curve objects for export, or to points or 
boundaries. Curves converted to boundaries are useful for mesh protection and surfacing. 

Planar free curves may be created and can be used to describe profile geometry. 

Free curves may be saved as an IGES file for import to an application that supports free curve geometry. 

Projected Curve Creation 

ACTIVITY: Projected Curve Creation 

Objective 
Learn how to extract and edit a curve object from a polygon object; commands covered in this section include: 

 Mesh Doctor 

 Extract 

 Draw 

 Convert to Boundaries 

Training File 
TR-09.wrp 

File Open 

 

1. Use your choice of methods to access 
the Open command. 

 Navigate to the training files folder 
and open TR-09.wrp. 

 

Figure 110 

Mesh Maintenance 

 
1. Click Scan > Repair > Mesh Doctor on the ribbon. 

 Click Apply if any errors in the mesh are found. 

 Click OK to exit the dialog. 

 Curve extraction and editing require a “clean” mesh for best operation; it is a good practice to check the mesh 
prior to any operations that require the use of curves. 

 Curves are also used in surfacing to create contours; a “clean” mesh is also required for surfacing. 
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Draw/Edit Projected Curves 
 1. Rotate the model and Zoom to the 

view as shown in Figure 111. 

 
Figure 111 

 
 
 
 
 
 
 
 
 
 

 

2. Click Model > Projected Curves > Draw on the ribbon. 

 There are several curve editing tools available, in this section we will focus on dragging the projected curves 
from the previous section to better align with the edges of the model. 

 Projected curves have red endpoints and yellow control points along their length, moving/adding or deleting a 
control point will affect the shape of the curve. Moving the endpoints will affect the position of the endpoint 
and shape of a curve near the endpoint edited. 

 As you cursor over an endpoint or control point a square selection box will appear indicating you can snap 
your cursor to that point. As you cursor over a curve segment a round selection circle will appear indicating 
you can snap your cursor to that curve segment.  

 Verify that the Draw icon is active (orange highlight). 

 3. Hover over each of the endpoints and control points until a selection box appears and 
click/drag to move each point to the new locations as shown in Figure 113. 

 If you make a mistake; use CTRL+Z to undo and try again. 

 Press F1 while hovering the cursor over the Draw Curves dialog for a full description of the editing tools; in 
particular the About the Draw Operations. For basic details on the available Operation tools, refer to Error! 
Not a valid bookmark self-reference. – Curve and Contour Operations 

 

 
Figure 112 - Before Curve Editing 

 
Figure 113 - After Curve Editing 
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 4. Rotate the model to the opposite side and place a checkmark in the Curvature Map 
checkbox in the Display roll-up group. 

 Use the Curvature Map and position the points as before on the areas of curvature 
as shown in Figure 114. 

 Turn off the curvature map by deselecting the Curvature Map option in the 
Display group of the dialog. 

 If you make a mistake; use CTRL+Z to undo and try again. 

 You can increase the curvature map intensity by pressing the “+” key and decrease the intensity of the 
curvature map by pressing the “-“ key. Green indicates little or no curvature. Rounds/edges are shaded to dark 
blue while radii are shaded to dark red. 

 

 
Figure 114 - Curvature Map Displayed 

 5. After editing and verifying that the curves are positioned correctly on the edges 
specified, click OK to exit the dialog. 

Convert Projected Curves to Boundaries 

 
1. Click Model > Projected Curves > 

Convert to > Boundaries on the ribbon. 

 The projected curves will be converted to Boundaries, 
see Figure 115. 

 Boundaries may be deleted by Polygons > Boundaries 
> Remove Boundary. 

 Boundaries will “fix” in place any triangles they touch; 
many commands including Decimate and Mesh Doctor 
will honor boundaries when operating on a mesh. 
Boundaries can also be used as constrained contours 
in surfacing. 

 
Figure 115 

End of Activity 
 



  
 

Copyright © 2019 3D Systems 83 Geomagic Essentials® 

 

Section Curves 
Free Curve object has no association with either the point or polygon model it is derived from and is an 
independent object in the Model Manager Panel. The Create by Section command creates a Free Curve object by 
either Cylindrical or Planar sections. Free Curve objects created with a cylindrical section are spline based and are 
not editable. Free Curve objects created by planar section may be either line/arc or spline based. Line/arc Free 
Curve objects are particularly useful for creating extrusion/revolve profiles in CAD systems. 
 
Free Curve objects may be derived from projected curves by using the Model > Projected Curves > Convert to > 
Free Curves command on the Curves ribbon. 
 
Line/arc planar sections are classified as Sketch objects in the Model Manager Panel and may be edited in the 
Sketch environment. 
 
All Free Curve sections may be transferred to CAD/CAM/CAE applications by way of IGES;  
 

ACTVITY:  Create by Section 

Objective 
Create a spline based curve using a planar section for downstream applications. 

 Create by Section 

Training File 
TR-10.wrp 

File Open 

 
1. Use your choice of methods to access the Open command. 

 Navigate to the training files folder and Open TR-10.wrp. 

Curve by Section (Spline) 

 
1. Click Model > Free Curves > Create by Section 

on the ribbon.  

 In the Section Type roll-up group; verify that 
Planar radio button is selected. 

 In the Align Plane roll-up group; verify that the 
Define drop-down list is set to System Plane 
and the Plane drop-down list is set to XY-
Plane. 

 In the Align Plane roll-up group set the 
Position value to 14.0 mm, press Enter to 
update the section plane position in the 
Graphics Window, see Figure 116. 

 In the Curve Properties roll-up group set 
Curve Type to Spline, set the Fitting drop-
down list to Tolerance and change the 
Tolerance value to 0.005 mm. 

 
Figure 116 
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2. Click Apply to fit the spline curve through the 
section. 

 You can view the fitting of the spline; make fitting adjustments 
and Apply again to update the fit of the spline curve at any time 
while in the dialog. 

 Click OK to exit the dialog. 

 A curve object is created in the Model Manager 
Panel, Right click and choose Hide on the root to 
view the new Free Curve object, see Figure 
117. 

 Free Curve objects may be saved as an IGES file for downstream 
applications. 

 
Figure 117 

Curve by Section (Line/Arc) 

 
1. Make the polygon object active by clicking it in the 

Model Manager Panel. 

 Click Model > Free Curves > Create by 
Section on the ribbon.  

 In the Section Type roll-up group; verify that 
Planar is selected. 

 In the Align Plane roll-up group; verify that the 
Define drop-down list is set to System Plane 
and set the Plane drop-down list to YZ-Plane. 

 In the Align Plane roll-up group set the 
Position value to 0.0 mm, press Enter to 
update the section plane position in the 
Graphics Window, see Figure 118. 

 The white section plane can be moved in the Graphics Window 
by holding the CTRL key down while click/dragging. 

 In the Curve Properties roll-up group set 
Curve Type to Line/Arc, set the Tolerance 
value to 0.05 mm. 

 
Figure 118 
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2. Click Apply to fit the line/arc curve through the 
section. 

 You can view the fitting of the curve section; make fitting 
adjustments and Apply again to update the fit of the curve at 
any time while in the dialog. 

 Using increasingly smaller values with the Line/Arc option active 
with produce more small circular arcs in your curve profile and 
vice versa. 

 Click OK to exit the dialog. 

 A curve object is created in the Model Manager 
Panel, Right click all other objects and Hide 
them to view the new Free Curve object, see 
Figure 119. 

 Line/Arc free curve objects may be edited in the Sketch 
environment. 

 
Figure 119 

End of Activity 
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Appendix 
Mouse Controls 
Right-Hand Mouse is shown 

 

MB1 

 Selection Button 
 Use to change ribbons or tabbed panels 
 Use to activate commands 
 Use to activate objects in the Model Manager Panel 
 Use to make selections the Graphics Window on the active 

object(s) by clicking or click/drag selection tool. 
 Move Command Plane 

 CTRL+Click to click/drag a command plane when a command 
has the Align Plane option 

 Model Manager Panel 
 SHIFT+Click on object in the graphics area to locate it in the 

Model Manager 
 Light Bulb 

 ALT+Click to move Graphics Window light bulb 

 

Scroll Wheel 

 Zoom 
 Zoom in or out by placing cursor at area of interest and rolling 

scroll wheel. Roll wheel away from you to decrease 
magnification, roll wheel towards you to increase 
magnification. 

 Pan 
 ALT+Click enables display panning in Graphics Window 

 Feature Selection 
 CTRL+Scroll cycles through the stack of feature that are within 

the selection zone of the cursor  
 Dialogs 

 Increases or decreases the value in a numeric field when the 
mouse cursor is located within a numeric input field 

MB2  Click and drag changes 3D view of objects in the Graphics Window 

 

MB3 

 Pan 
 ALT+Click enables display panning in Graphics Window 

 Pop-Up Menu’s 
 Single click in the Graphics Window will display a pop-up menu 

of common commands 
 Click on object in Model Manager Panel to display context 

menu 
 Click on UI elements to display UI context menu 

Right-Hand Mouse Arrangement:  
 MB1= Left Mouse Button (LMB) 
 MB2 = Middle Mouse Button (MMB) 
 MB3 = Right Mouse Button (RMB) 

Left-Hand Mouse Arrangement:  
 MB1= Left Mouse Button (RMB) 
 MB2 = Middle Mouse Button (MMB) 
 MB3 = Right Mouse Button (LMB) 
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Hot Keys 
Listed in the table are the default Hot Keys. These hot keys will allow you to access certain commands quickly 
without selecting the command from the Menu Bar or a Tool Bar. 

 
CTRL+N New File 
CTRL+O Open File 
CTRL+S Save File 
CTRL+Z Undo 
CTRL+Y Redo 
CTRL+T Activate Rectangle Selection Tool 
CTRL+L Activate Lasso Selection Tool 
CTRL+P Activate Paintbrush Selection Tool 
CTRL+U Activate Custom Region Selection Tool 
CTRL+W Activate Polyline Selection Tool 
CTRL+V Toggle Select Visible / Select Through 
CTRL+A Select All 
CTRL+C Clear All 
CTRL+F Set Rotation Center 
CTRL+R Reset Current View 
CTRL+B Reset Bounding Box 
F1 Activate Help 
F5 Select All Objects of Same Type as Active Object 
F12 Toggle On / Off Transparency 
ESC Interrupt Operation 
DEL Delete; Points, Polygons, Faces, Curves, Surfaces 
CTRL+X Application Options 

 

 

 

 

 

 

 

Options 
When first opened, the Frequently Used page is displayed. Other settings are for more advanced users. The 
Frequently Used options are described below:  

Frequently Used 
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Directories 
The default directory for opening and saving data files. 
Workspace 
Defines the default settings for: 
- Decimal Places 
- Unit system 
- Language 
- Color Scheme. 
 
Display Size 
Controls the default pixel size of commonly displayed primitives and geometry types in the Graphics Window. 
Selection Tools 
Defaults settings in pixels for the Paintbrush and Line selection tools. 
Invert Scroll Wheel Zoom 
Toggles the magnification direction of the Zoom command on the mouse scroll wheel.  
Enable Spaceball 
This option will toggle on/off the use of a Spaceball connected to the system. 
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ACTIVITY: User Interface Customizations 
 To locate where all system files are located; click the Directories category and view the disk paths on the option page. 

System paths change based on operating system version in use. 

 
1. Change the location of the Default Open Directory. 

 Click the Application Button > Options. 

 Click Frequently Used (default). 

 Locate the Default Open Directory option at the top of the page. 

 Change the path using the Browse button to a directory containing data files for 
Geomagic Essentials. 

 Click OK to exit. 

 

Quick Access Toolbar 
 1. The Quick Access Toolbar (QAT) is located by default above the main ribbon bar at 

the top left edge of the application window. The QAT by default contains the Open 
(file), Save (file), Undo and Redo commands. 

 An expansion arrow is located at the right end of the QAT, see Figure 120. When 
clicked, options for the QAT are presented. 

 
Figure 120 

 Click on the QAT expansion button. 

 From the QAT options menu, select Show Below the Ribbon. The QAT will be 
positioned below the main ribbon bar. 

 Click on the QAT expansion button again. 

 From the QAT options menu, select Show Above the Ribbon. The QAT will be 
positioned above the main ribbon bar at its default location. 

 2. Any command on the ribbon can be added to the QAT, a maximum of 50 commands 
may be added to the QAT. 

 Click View > Navigation > Rotation Center down arrow on the ribbon; the menu 
of options for the Rotation Center command will appear. Instead of activating a 
command, RMB click on Set Rotation Center and select Add to Quick Access 
Toolbar from the options menu. 

 The Set Rotation Center icon will appear on the QAT. 

 To remove a command from the QAT; RMB click the Set Rotation Center icon on 
the QAT and select Remove From Quick Access Toolbar on the options menu. 

 The process for adding and removing commands on the QAT are the same for every command on the ribbon 
bar. This enables you to have commands from different tabs and be able to invoke frequently used commands 
without tab switching. 

End of Activity 
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